Re: [PATCH v3 02/16] mm/page_alloc: some renames to clarify alloc_flags scopes
From: Vlastimil Babka (SUSE)
Date: Tue Jun 30 2026 - 08:38:48 EST
On 6/29/26 15:11, Brendan Jackman wrote:
> It's pretty confusing that:
>
> - The slowpath and fastpath have a totally distinct set of alloc_flags.
>
> - gfp_to_alloc_flags() sounds generic but it only influences the
> slowpath.
>
> Rename some variables to highlight which alloc_flags are
> fastpath-specific. Rename gfp_to_alloc_flags() to highlight that it's
> slowpath-specific.
>
> gfp_to_alloc_flags_cma() and gfp_to_alloc_flags_nonblocking() currently
> have perfectly harmless names, but to keep the naming consistent also
> rename those to the alloc_flags_*() pattern (which already exists for
> alloc_flags_nofragment()).
How annoying that alloc_flags_nofragment() doesn't have gfp as the first
parameter, unlike others.
Oh well, must resist too much OCD :)
Uh, more annoyingly, alloc_flags_cma() takes alloc_flags and returns
augmented alloc flags, so there's stuff like
*alloc_flags = alloc_flags_cma(gfp_mask, *alloc_flags);
Since we're unifying, it could be make to work additively like others? Then:
*alloc_flags |= alloc_flags_cma(gfp_mask);
> Signed-off-by: Brendan Jackman <jackmanb@xxxxxxxxxx>
Otherwise, LGTM.
Reviewed-by: Vlastimil Babka (SUSE) <vbabka@xxxxxxxxxx>