Re: [PATCH 1/4] rtc: palmas: convert to dev_err_probe()
From: Alexandre Mergnat
Date: Tue Jun 30 2026 - 13:14:27 EST
On Thu, 28 May 2026 09:16:44 +0530, Balakrishnan Sambath <balakrishnan.s@xxxxxxxxxxxxx> wrote:
> diff --git a/drivers/rtc/rtc-palmas.c b/drivers/rtc/rtc-palmas.c
> index aecada6bcf8b..25fe7a8b73a0 100644
> --- a/drivers/rtc/rtc-palmas.c
> +++ b/drivers/rtc/rtc-palmas.c
> @@ -280,10 +278,8 @@ static int palmas_rtc_probe(struct platform_device *pdev)
> ret = palmas_update_bits(palmas, PALMAS_RTC_BASE, PALMAS_RTC_CTRL_REG,
> PALMAS_RTC_CTRL_REG_STOP_RTC,
> PALMAS_RTC_CTRL_REG_STOP_RTC);
> - if (ret < 0) {
> - dev_err(&pdev->dev, "RTC_CTRL write failed, err = %d\n", ret);
> - return ret;
> - }
> + if (ret < 0)
> + return dev_err_probe(&pdev->dev, ret, "RTC_CTRL write failed\n");
The enable_bb_charging block earlier in this function (the two
palmas_update_bits() / "BACKUP_BATTERY_CTRL update failed" error paths)
follows the same dev_err()+return ret pattern but is left unconverted.
Converting those too keeps the whole probe consistent.
It's purely about readability, not correctness, so I give my RB.
Reviewed-by: Alexandre Mergnat <amergnat@xxxxxxxxxxxx>
--
Alexandre Mergnat <amergnat@xxxxxxxxxxxx>