[PATCH v2 0/3] mm/migrate: preparatory cleanups for batch copy and offload
From: Shivank Garg
Date: Wed Jul 01 2026 - 01:17:58 EST
This is a small set of mm/migrate cleanups split out of the batch-copy
and offload RFC [1], so they can be reviewed and merged independently
ahead of that larger series.
No functional change intended.
[1] https://lore.kernel.org/all/20260428155043.39251-2-shivankg@xxxxxxx
Signed-off-by: Shivank Garg <shivankg@xxxxxxx>
---
Changes in v2:
- Rename folio/page_was_mapped to was_mapped and unmap_and_move_huge_page
to unmap_and_move_hugetlb_folio (David).
- Fix stale "page" wording in comment.
- Rebase to mm-new.
- Link to v1: https://lore.kernel.org/r/20260626-migrate-cleanups-prep-v1-0-a95933af7619@xxxxxxx
---
Shivank Garg (3):
mm/migrate: rename page to folio leftovers
mm/migrate: fix stale list name in migrate_folios_move() comment
mm/migrate: use migrate_info field instead of private
include/linux/mm_types.h | 1 +
mm/migrate.c | 52 +++++++++++++++++++++++-------------------------
2 files changed, 26 insertions(+), 27 deletions(-)
---
base-commit: 15654b0268cd65b4e673510c0377774e61b86397
change-id: 20260626-migrate-cleanups-prep-77a0ad340cc6
Best regards,
--
Shivank Garg <shivankg@xxxxxxx>