Re: [PATCH v5 1/2] PM: sleep: Rename module parameters prefix to "pm_sleep"

From: Tzung-Bi Shih

Date: Thu Jul 02 2026 - 02:13:30 EST


On Wed, Jul 01, 2026 at 01:27:04PM +0200, Rafael J. Wysocki (Intel) wrote:
> On Wed, Jul 1, 2026 at 9:20 AM Greg Kroah-Hartman
> <gregkh@xxxxxxxxxxxxxxxxxxx> wrote:
> >
> > On Wed, Jul 01, 2026 at 04:56:39AM +0000, Tzung-Bi Shih wrote:
> > > Currently, the module parameters defined in drivers/base/power/main.c
> > > use the default prefix "main" (derived from the filename). The prefix
> > > is too generic and non-descriptive.
> > >
> > > Redefine MODULE_PARAM_PREFIX to "pm_sleep." to group the module
> > > parameters under the namespace instead. This makes the parameters more
> > > descriptive.
> >
> > You just changed the user/kernel api, right? That will break things...
>
> Or not, if that part of the ABI is not really used or the users of it
> can live with the change.
>
> This actually is an attempt to correct a mistake in the ABI and only
> one module parameter is affected by this change
> (dpm_watchdog_all_cpu_backtrace). I'm not expecting the people using
> it to get a particular heartburn about the change. Or if they do,
> we'll back off.

To provide a bit more context (also discussed previously in v3 [1][2]):
The `dpm_watchdog_all_cpu_backtrace` parameter is relatively new. It was
introduced in v6.19 (Oct 2025) via commit a67818f74512 ("PM: dpm_watchdog:
add module param to backtrace all CPUs"). Because of its recent
introduction, it shouldn't have many users in the wild yet. The flag was
originally introduced for ChromeOS [3], which doesn't actually rely on this
module parameter in its production configuration yet [4].

Given the limited known usage, this is likely the best window to correct
the prefix before it gains wider adoption.

[1] https://lore.kernel.org/all/aigPNvkxRIz36dWm@xxxxxxxxxx
[2] https://lore.kernel.org/all/CAJZ5v0gQTx_k9j2pGha7NKxAjdPS1J_ySZNYiL1=_+_M9znQ_g@xxxxxxxxxxxxxx
[3] https://crrev.com/c/7414781
[4] https://crrev.com/c/7414721

>
> I'm now thinking though that using "pm" as the new prefix might be better.

Ack, we can change it back to "pm." in the next version.