Re: [PATCH 2/4] firmware: qcom: scm: use __free(qcom_tzmem) to simplify cleanup

From: Konrad Dybcio

Date: Thu Jul 02 2026 - 06:32:18 EST


On 7/1/26 3:38 PM, Bartosz Golaszewski wrote:
> Use the __free(qcom_tzmem) cleanup attribute (together with no_free_ptr()
> whenever ownership is transferred) to replace open-coded
> qcom_tzmem_free() calls and their associated goto labels.
>
> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxxxxxxxx>
> ---

Reviewed-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxxxxxxxx>

Konrad