Re: [PATCH v2] rust: iommu: replace core::mem::zeroed with Zeroable::zeroed

From: Alice Ryhl

Date: Thu Jul 02 2026 - 07:32:33 EST


On Mon, Jun 29, 2026 at 05:10:41PM -0300, Nicolás Antinori wrote:
> All types in `bindings` implement `Zeroable` if they can. This enables
> using `Zeroable::zeroed` for `io_pgtable_cfg` initialization instead
> of relying on `..unsafe { core::mem::zeroed() }`.
>
> This change improves readability and removes an unnecessary unsafe
> block.
>
> Link: https://github.com/Rust-for-Linux/linux/issues/1189
> Suggested-by: Benno Lossin <lossin@xxxxxxxxxx>
> Signed-off-by: Nicolás Antinori <nico.antinori.7@xxxxxxxxx>

Reviewed-by: Alice Ryhl <aliceryhl@xxxxxxxxxx>

Joerg, is this cleanup you can pick up? Thanks!