Re: [PATCH v2 02/18] xfs: convert iomap ops to ->iomap_next()
From: Christoph Hellwig
Date: Thu Jul 02 2026 - 10:06:03 EST
> - * The retry mechanism is based on the ->iomap_begin method returning
> + * The retry mechanism is based on the ->iomap_next method returning
Nit: Maybe the drop the "->" in preparation of the last patch that would
make it slightly misleading with the ops struct removal?
> +static int
> +xfs_direct_write_iomap_next(
> + const struct iomap_iter *iter,
> + struct iomap *iomap,
> + struct iomap *srcmap)
> +{
> + return iomap_process(iter, iomap, srcmap, xfs_direct_write_iomap_begin,
> + NULL);
> +}
I wonder if we want a "simple" version of iomap_process that only takes
a begin callback, as most current ops seems to be that way. Then again
between needing at least one longer function name it's probably not
helping much with readability. So not sure, just dropping it here if
anyone has a good idea or storng opinion.
Otherwise looks good:
Reviewed-by: Christoph Hellwig <hch@xxxxxx>