Re: [PATCH v5 2/3] pwm: rp1: Add RP1 PWM controller driver

From: Andrea della Porta

Date: Fri Jul 03 2026 - 10:53:35 EST


Hi Julian,

On 11:29 Mon 15 Jun , Julian Braha wrote:
> Hi Uwe,
>
> On 6/15/26 07:37, Uwe Kleine-König wrote:
> > IMHO selecting REGMAP_MMIO explicitly here is fine because at least to
> > me it's not obvious that MFD_SYSCON enforces REGMAP_MMIO.
>
> I think it's better to use comments to document non-obvious behavior,
> rather than dead code.
> E.g.:
> 'select MFD_SYSCON # selects REGMAP_MMIO'
>
> But I guess this is not really worth bikeshedding over.

Honestly I don't have a strong opinion on that, but documenting is basically
the same than just selecting the option (well with the addition of the #), so
not really a difference. If there's no major concern about that I also wouuld
prefer to expicitly declare teh selecion of REGMAP_MMIO.

Many thanks,
Andrea

>
> - Julian Braha