Re: [PATCH RESEND] sched/mmcid: Use clamp() to simplify mm_cid_calc_pcpu_thrs()
From: David Laight
Date: Sun Jul 05 2026 - 15:09:24 EST
On Sun, 5 Jul 2026 19:20:54 +0200
Thorsten Blum <thorsten.blum@xxxxxxxxx> wrote:
> Use clamp() to simplify the code and improve its readability.
>
> Signed-off-by: Thorsten Blum <thorsten.blum@xxxxxxxxx>
> ---
> kernel/sched/core.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/sched/core.c b/kernel/sched/core.c
> index 8b791e9e9f67..31739bd43176 100644
> --- a/kernel/sched/core.c
> +++ b/kernel/sched/core.c
> @@ -10785,7 +10785,7 @@ static inline unsigned int mm_cid_calc_pcpu_thrs(struct mm_mm_cid *mc)
>
> opt_cids = min(mc->nr_cpus_allowed, mc->users);
> /* Has to be at least 1 because 0 indicates PCPU mode off */
> - return max(min(opt_cids - opt_cids / 4, num_possible_cpus() / 2), 1);
> + return clamp(opt_cids - opt_cids / 4, 1, num_possible_cpus() / 2);
Nack, it isn't the same.
clamp() requires that lo <= hi but I suspect num_possible_cpus()
can be zero.
IIRC clamp(val, lo, hi) is currently val > hi ? hi : val < lo ? lo : val
so the above doesn't even generate the desired answer.
But relying on the is a bug anyway.
It would be nice to swap the order so that clamp(-5, 0, 5u) could be valid
and have the expected value.
David
> }
>
> static bool mm_update_max_cids(struct mm_struct *mm)
>