Re: [PATCH v7 0/3] mm: clean up folio LRU and swap declarations

From: Andrew Morton

Date: Sun Jul 05 2026 - 15:21:50 EST


On Sun, 05 Jul 2026 22:12:30 +0800 Jianyue Wu <wujianyue000@xxxxxxxxx> wrote:

> This series splits folio LRU and swap cleanup into three steps:
>
> - move the page-cluster sysctl next to swap readahead in mm/swap_state.c
> - rename mm/swap.c to mm/folio.c after the swap-specific bits move out
> - move MM-internal reclaim declarations out of include/linux/swap.h
>
> After this series, swap cache and swap-in readahead stay in mm/swap_state.c,
> folio LRU helpers live in mm/folio.c, and MM-internal reclaim/workingset
> declarations move from include/linux/swap.h to mm/internal.h (public LRU
> helpers used outside mm/ remain in swap.h).

Thanks, I've added this to mm.git's mm-new branch - in a few days I'll
move it into mm-unstable for linux-next inclusion. After -rc4 (approx)
I'll move it into mm.git's non-rebasing mm-stable branch for
upstreaming during the 7.3-rc1 merge window.