Re: [PATCH v2 2/4] arm64: dts: qcom: shikra-cqm-evk: Enable display and add ili7807s panel
From: Dmitry Baryshkov
Date: Mon Jul 06 2026 - 09:59:40 EST
On Mon, Jul 06, 2026 at 11:19:59AM +0200, Krzysztof Kozlowski wrote:
> On 06/07/2026 10:52, Arpit Saini wrote:
> > Hi Krzyszto,
> >
> > On 7/6/2026 12:03 PM, Krzysztof Kozlowski wrote:
> >> On 06/07/2026 08:04, Nabige Aala wrote:
> >>> + lcd_bias: regulator-lcd-bias {
> >>> + compatible = "regulator-fixed";
> >>> + regulator-name = "lcd_bias";
> >>> + vin-supply = <&vph_pwr>;
> >>> + gpio = <&tlmm 151 GPIO_ACTIVE_HIGH>;
> >>> + enable-active-high;
> >>> + pinctrl-0 = <&lcd_bias_en>;
> >>> + pinctrl-names = "default";
> >>> + };
> >>> +
> >>> + vph_pwr: vph-pwr-regulator {
> >> Why so inconsistent names?
> >>
> >> Anyway, drop the node, not used and not controllable.
> >
> > As per the schematics of LCD display Bias driver , vph_pwr is used as
> > vin for that.
> >
> > So I created vph_pwr , if you want , I can drop that in next patchset.
>
> But vph_pwr gets its own supply from main power, which gets from socket,
> which gets from building wiring, which gets from a power plant... Drop
> the node, as I said, it is redundant in DTS.
Just for my understanding. Is it fine if it gets used as an input to
PMICs?
>
> Best regards,
> Krzysztof
--
With best wishes
Dmitry