Re: [PATCH] scsi: ufs: ufshcd: use str_enabled_disabled() for Write Booster messages
From: Bart Van Assche
Date: Mon Jul 06 2026 - 10:52:00 EST
On 7/1/26 10:51 AM, Animesh Rai wrote:
Replace open-coded ternary expressions of the form
enable ? "enabled" : "disabled"
with the str_enabled_disabled() helper from <linux/string_choices.h>.
This reduces code duplication and allows the linker to deduplicate the
constant strings across the kernel image.
This patch doesn't look like an improvement to me. I don't think that we
need this patch.
Bart.