Re: [PATCH 2/3] null_blk: give the file-scope mutex a descriptive name
From: Bart Van Assche
Date: Mon Jul 06 2026 - 11:06:57 EST
On 7/6/26 6:21 AM, Zizhi Wo wrote:
Thanks for the reminder! Agreed that "nullb_list_lock" is too narrow
since it also serializes nullb_device_power_store() and
nullb_update_nr_hw_queues().
However, I'm a bit worried that "nullb_lock" is easy to confuse with the
per-device spinlock "nullb->lock"... They are only one "->" apart?
Would "nullb_global_lock" (or "nullb_config_lock") work better? It
reflects the broader purpose and avoids clashing with nullb->lock.
Not sure what others prefer but nullb_global_lock sounds good to me.
Thanks,
Bart.