Re: [PATCH RFC 10/13] drm/msm: initialize LPAC ring
From: Anna Maniscalco
Date: Mon Jul 06 2026 - 18:13:57 EST
On 7/6/26 11:56 PM, Akhil P Oommen wrote:
On 7/6/2026 4:37 PM, Anna Maniscalco wrote:That could be more intuitive yeah
On 7/6/26 10:44 AM, Konrad Dybcio wrote:We can introduce a new QUIRK (ADRENO_QUIRK_LPAC?).
On 7/5/26 9:13 PM, Anna Maniscalco wrote:That's correct yeah. I'm not sure what has_lpac should be though.
Program all the register needed to start up LPAC and send initializationI believe some/all of these writes need to be guarded by if (has_lpac),
sequence.
Additionally, now that the LPAC ring is live, make the code aware of it.
Signed-off-by: Anna Maniscalco <anna.maniscalco2000@xxxxxxxxx>
---
as many GPUs lack these registers and there may be side effects on
others
Something we add to catalog? Or checking if it is a gen that has LPAC?
How about nr_gfx_rings as those rings can handle graphics workload?Qualcom calls it GC so nr_gc_rings perhaps?
[...]
a6xx_gpu->shadow = msm_gem_kernel_new(gpu->dev,Should we rename nr_rings to something like nr_XXX_rings
- sizeof(u32) * gpu->nr_rings,
+ sizeof(u32) * (gpu->nr_rings + !!gpu-
lpac_rb),
where XXX is some uarch-generic (i.e. not SQE because we also
support pre-a6xx) name for the main number cruncher?
-Akhil.
Konrad
Best regards,
Best regards,
--
Anna Maniscalco <anna.maniscalco2000@xxxxxxxxx>