Re: [PATCH v5] staging: sm750fb: rename variables to comply with kernel style
From: Greg Kroah-Hartman
Date: Wed Jul 08 2026 - 01:03:46 EST
On Tue, Jul 07, 2026 at 05:15:41PM -0300, André Moreira wrote:
> Rename 'setAllEngOff' to 'set_all_eng_off' within the 'init_status'
> struct to avoid CamelCase and comply with the Linux kernel coding style.
> Also update its usage within sm750.c to prevent compilation errors.
>
> Signed-off-by: André Moreira <andrem.33333@xxxxxxxxx>
> ---
> v5:
> - Fix broken diff from v4 that was accidentally recreating the entire struct.
> - Update the variable usage inside drivers/staging/sm750fb/sm750.c to
> prevent compilation errors.
>
> v4:
> - Drop register renames 'pvReg' to 'regs' as they were merged via another upstream patch.
> - Keep only the 'init_status' CamelCase cleanup.
>
> v3:
> - Added changelog history to satisfy the bot.
>
> v2:
> - Renamed 'pv_reg' to 'regs' to completely remove Hungarian notation, based on Greg KH's feedback.
>
> drivers/staging/sm750fb/sm750.c | 2 +-
> drivers/staging/sm750fb/sm750.h | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c
> index 89c811e0806c4..00c293430a7d5 100644
> --- a/drivers/staging/sm750fb/sm750.c
> +++ b/drivers/staging/sm750fb/sm750.c
> @@ -848,7 +848,7 @@ static void sm750fb_setup(struct sm750_dev *sm750_dev, char *src)
> sm750_dev->init_parm.mem_clk = 0;
> sm750_dev->init_parm.master_clk = 0;
> sm750_dev->init_parm.power_mode = 0;
> - sm750_dev->init_parm.setAllEngOff = 0;
> + sm750_dev->init_parm.set_all_eng_off = 0;
> sm750_dev->init_parm.reset_memory = 1;
>
> /* defaultly turn g_hwcursor on for both view */
> diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
> index d2c522e67f26a..589ae51444f81 100644
> --- a/drivers/staging/sm750fb/sm750.h
> +++ b/drivers/staging/sm750fb/sm750.h
> @@ -44,7 +44,7 @@ struct init_status {
> ushort chip_clk;
> ushort mem_clk;
> ushort master_clk;
> - ushort setAllEngOff;
> + ushort set_all_eng_off;
> ushort reset_memory;
> };
>
If this variable is only set, and never read, why is it here at all?
Why not just remove it entirely?
thanks,
greg k-h