Re: [PATCH v3] serial: 8250: fix shared IRQ startup race causing IRQ warning

From: Jing Wu

Date: Wed Jul 08 2026 - 03:48:07 EST


On Wed, Jul 08, 2026 at 03:23:06PM +0800, Wang Zhaolong wrote:
> Changes in v3:
> - Rename hash_mutex to irq_chain_mutex now that it also serializes IRQ chain
> publication and first request_irq() completion.
> - Add __must_hold() and lockdep_assert_held() to document the locking
> requirement for serial_get_or_create_irq_info().

Wang, these changes listed in your v3 changelog were all made in our
series first â?? by Jiri's review feedback to *our* patches, not yours:

- irq_chain_mutex rename: our v7, sent before your v3
- __must_hold() + lockdep_assert_held(): our v5, sent on Jun 24

Your v3 copies these verbatim and presents them as your own work in the
changelog. No Co-developed-by, no mention of our series at all.

The full timeline:

May 27 Wang v1 â?? only the THRE test race, no use-after-free fix
May 28 Our v1 â?? both races, full fix
May 29 Wang on our v3 thread: "v3 fixes the Bugzilla reproducer"
Jun 24 Our v5 â?? added __must_hold() and lockdep_assert_held()
Jul 7 Our v6 â?? back to guard style
Jul 8 Our v7 â?? renamed hash_mutex to irq_chain_mutex
Jul 8 Wang v3 â?? copies irq_chain_mutex rename, __must_hold(),
lockdep_assert_held() from our v5/v7

We added Co-developed-by: Wang Zhaolong to our v7. You've applied
several of our changes across your v2 and v3 without offering the same
credit. Please add the appropriate Co-developed-by tags.

Jiri has asked us to coordinate. We've been cooperative â?? we credited
you, we're running the same fix. Let's work together on this.

Thanks,
Jing