Re: [PATCH] mm/kconfig: Drop redundant memory hotplug dependencies

From: Julian Braha

Date: Wed Jul 08 2026 - 10:15:37 EST


Hi Kaitao,

On 7/7/26 10:03, Kaitao Cheng wrote:
> MHP_MEMMAP_ON_MEMORY is defined inside the MEMORY_HOTPLUG block, and
> MEMORY_HOTPLUG already depends on SPARSEMEM_VMEMMAP. Keep the explicit
> MEMORY_HOTPLUG dependency for local readability, but drop the redundant
> SPARSEMEM_VMEMMAP dependency.

I love a good kconfig cleanup, but why keep both the
'if MEMORY_HOTPLUG..endif' and the 'depends on MEMORY_HOTPLUG'?

The "local readability" could be achieved with a comment if keeping the
'if..endif'.

And if we don't want the comment and would prefer the explicit
'depends on', then why not remove the 'if..endif'?

- Julian Braha