Re: [PATCH 1/7] mm/damon/core: remove comment and test for nr_to_bp() divide-by-zero

From: SJ Park

Date: Wed Jul 08 2026 - 10:38:22 EST


On Wed, 8 Jul 2026 06:53:51 -0700 SJ Park <sj@xxxxxxxxxx> wrote:

> The comments on damon_nr_accesses_to_accesses_bp() and its unit test
> warn it can trigger division-by-zero when the aggregation interval is
> zero. Commit 35d4a3cf70a8 ("mm/damon/ops-common: handle extreme
> intervals in damon_hot_score()") modified damon_nr_samples_per_aggr() to

I mistakenly used the future name of damon_max_nr_accesses() on the above
sentence. Andrew, could you please fix the above sentence by doiing
s/nr_samples_per_aggr/max_nr_accesses/ when you pick this up?

Please let me know if you prefer v2.


Thanks,
SJ

[...]