Re: [PATCH] x86/virt/tdx: Formalize SEAMCALL version encoding support

From: Dave Hansen

Date: Wed Jul 08 2026 - 10:50:32 EST


On 7/6/26 14:44, Edgecombe, Rick P wrote:
>> Two alternative schemes were considered:
>>
>> 1. Define versioned macros like TDH_VP_INIT_V0, TDH_VP_INIT_V1, etc.
>> However, this breaks naming consistency unless all existing stable
>> function macros are changed to TDH_XXX_V0.
>>
>> 2. Add an explicit 'version' parameter to the base seamcall() API. This
>> unnecessarily forces all stable SEAMCALL helpers to pass a
>> meaningless '0' argument. Additionally, the magic '0' or '1' values
>> at caller sites are not descriptive.
>>
> Dave was recently saying something to the effect of "make every word count". I
> think we could lose some filler words.

This can also just go below the --- so it doesn't make it to the final
changelog.

I like the discussion happening so far. I, too, dislike adding another
level of C wrappers. I'm looking forward to v2.