Re: [PATCH] watchdog: Fix typo in WATCHDOG_SOFTOCKUP_ENABLED macros

From: Doug Anderson

Date: Wed Jul 08 2026 - 11:23:53 EST


Hi,

On Wed, Jul 8, 2026 at 1:21 AM Daizhiyuan <daizhiyuan@xxxxxxxxxxxxxx> wrote:
>
> The macro WATCHDOG_SOFTOCKUP_ENABLED and its companion bit macro
> WATCHDOG_SOFTOCKUP_ENABLED_BIT are missing an 'L' in their names,
> resulting in 'SOFTOCKUP' instead of 'SOFTLOCKUP'.
>
> Rename them to WATCHDOG_SOFTLOCKUP_ENABLED and
> WATCHDOG_SOFTLOCKUP_ENABLED_BIT respectively across the header file
> and kernel/watchdog.c to fix the typo and maintain naming consistency.
>
> Signed-off-by: Daizhiyuan <daizhiyuan@xxxxxxxxxxxxxx>
> ---
> include/linux/nmi.h | 4 ++--
> kernel/watchdog.c | 12 ++++++------
> 2 files changed, 8 insertions(+), 8 deletions(-)

I believe this is a dupe of:

https://lore.kernel.org/r/20260615174557.1836562-1-edcr1790@xxxxxxxxx

...which has already been picked up by Andrew.