Re: [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
From: Oleg Nesterov
Date: Wed Jul 08 2026 - 11:59:35 EST
On 07/07, Thomas Gleixner wrote:
>
> The return value of that function is boolean and tells the caller whether
> to permit the syscall processing or not.
>
> Rename the function so the purpose is clear and make the return type bool.
Just in case,
Acked-by: Oleg Nesterov <oleg@xxxxxxxxxx>