[PATCH 0/6] vDSO: Clean up the HAVE_GENERIC_VDSO kconfig symbol
From: Thomas Weißschuh
Date: Thu Jul 09 2026 - 03:31:39 EST
Simplify the usage of HAVE_GENERIC_VDSO and rename it to better match
its function.
Signed-off-by: Thomas Weißschuh <thomas.weissschuh@xxxxxxxxxxxxx>
---
Thomas Weißschuh (6):
futex: Remove dependency on HAVE_GENERIC_VDSO from FUTEX_ROBUST_UNLOCK
vDSO: Remove the dependency on HAVE_GENERIC_VDSO from ARCH_HAS_VDSO_ARCH_DATA
MIPS: vdso: Stop using CONFIG_HAVE_GENERIC_VDSO
vDSO: Automatically select HAVE_GENERIC_VDSO if necessary
vDSO: Drop HAVE_GENERIC_VDSO from architecture kconfig files
vDSO: Rename HAVE_GENERIC_VDSO to VDSO_DATASTORE
arch/Kconfig | 1 -
arch/arm/mm/Kconfig | 1 -
arch/arm64/Kconfig | 1 -
arch/loongarch/Kconfig | 2 +-
arch/mips/Kconfig | 1 -
arch/mips/kernel/vdso.c | 4 ++--
arch/powerpc/Kconfig | 2 +-
arch/riscv/Kconfig | 8 ++++----
arch/s390/Kconfig | 1 -
arch/sparc/Kconfig | 1 -
arch/x86/Kconfig | 1 -
include/linux/vdso_datastore.h | 6 +++---
init/Kconfig | 2 +-
lib/vdso/Kconfig | 8 +++-----
lib/vdso/Makefile | 2 +-
15 files changed, 16 insertions(+), 25 deletions(-)
---
base-commit: 369cecd238ac8317cccd27cf2452a8a6b6da1581
change-id: 20260708-vdso-have_generic_vdso-478346d5c859
Best regards,
--
Thomas Weißschuh <thomas.weissschuh@xxxxxxxxxxxxx>