Re: [PATCH 6/6] vDSO: Rename HAVE_GENERIC_VDSO to VDSO_DATASTORE
From: Philippe Mathieu-Daudé
Date: Thu Jul 09 2026 - 07:31:54 EST
On 9/7/26 09:28, Thomas WeiÃschuh wrote:
Over time the meaning of HAVE_GENERIC_VDSO has become off.
Today it only controls the availability of the vDSO datastore.
Rename the symbol to match its function.
Signed-off-by: Thomas Weißschuh <thomas.weissschuh@xxxxxxxxxxxxx>
---
arch/loongarch/Kconfig | 2 +-
arch/powerpc/Kconfig | 2 +-
arch/riscv/Kconfig | 2 +-
include/linux/vdso_datastore.h | 6 +++---
lib/vdso/Kconfig | 6 +++---
lib/vdso/Makefile | 2 +-
6 files changed, 10 insertions(+), 10 deletions(-)
Reviewed-by: Philippe Mathieu-Daudé <philmd@xxxxxxxxxxxxxxxx>