Re: [f2fs-dev] [RFC PATCH v2 02/10] f2fs: carry subpage offset and count in write IO
From: Chao Yu
Date: Thu Jul 09 2026 - 23:04:36 EST
On 7/10/26 09:15, Nanzhe Zhao wrote:
How about cleaning up w/ below macros?
#define F2FS_FOLIO_INDEX(folio, fio) (folio->index + fio->folio_offset)
#define F2FS_FOLIO_BLKCNT(fio) (fio->folio_blkcnt ? fio->folio_blkcnt : 1)
F2FS_FOLIO_XXX naming seems a bit weird to me :). It does not show that
we want to use the folio subpage index associated with fio, or the blkcnt
recorded in fio. I think names like F2FS_FIO_LBLK and F2FS_FIO_BLKCNT
may be better?
Looks fine to me. :)
Thanks,