[Question] list_add() naming: why not list_add_head()?

From: Ziran Zhang

Date: Thu Jul 09 2026 - 23:22:23 EST


I noticed list_add() inserts at the head->next,
but the name doesn't reflect that.
Why wasn't it called list_add_head()? Is there
any historical or design reason?

Thanks for your time.

Regards,
Ziran Zhang