Re: [PATCH v3] fs/pipe: unify the page pools into a single per-pipe pool

From: Breno Leitao

Date: Fri Jul 10 2026 - 04:43:45 EST


On Thu, Jul 09, 2026 at 03:53:21PM +0200, Mateusz Guzik wrote:
> On Thu, Jul 9, 2026 at 3:38 PM Breno Leitao <leitao@xxxxxxxxxx> wrote:
> > anon_pipe_trim_pool_and_unlock() trims the pool under that same lock
> > before dropping it, then frees the excess.
>
> One nit, but probably not worth respining: the naming is slightly off
> in that either both routines or neither of them should mention 'pool',
> as opposed to just one side doing it.
>
> Perhaps Christian would be kind enough to either
> s/anon_pipe_prefill_and_lock/anon_pipe_prefill_pool_and_lock/ or
> s/anon_pipe_trim_pool_and_unlock/anon_pipe_trim_and_unlock/
>
> >
> > A huge thanks to Mateusz Guzik <mjguzik@xxxxxxxxx> who has been
> > a solid collaborator.
>
> well I wrote like twice that this kind of credit is not necessary
> here, but i'm not going to insist :-P
>
> that said, the patch reads fine to me now, so:
> Reviewed-by: Mateusz Guzik <mjguzik@xxxxxxxxx>

Ack, let me respin it with the two items above fixed.

Thanks for the review,