Re: [RFC PATCH 06/11] media: iris: Add hooks for pixel and non-pixel context banks
From: Dmitry Baryshkov
Date: Fri Jul 10 2026 - 12:06:44 EST
On Fri, Jul 10, 2026 at 12:02:46PM +0530, Vikash Garodia wrote:
>
>
> On 7/9/2026 6:44 PM, Dmitry Baryshkov wrote:
> > On Thu, Jul 09, 2026 at 06:05:52PM +0530, Vikash Garodia wrote:
> > > Iris platforms use separate context-bank devices for the pixel and
> > > non-pixel domains. Add platform hooks to create and destroy those
> > > subdevices, and wire them up for the affected platforms.
> > >
> > > Co-developed-by: Vishnu Reddy <busanna.reddy@xxxxxxxxxxxxxxxx>
> > > Signed-off-by: Vishnu Reddy <busanna.reddy@xxxxxxxxxxxxxxxx>
> > > Signed-off-by: Vikash Garodia <vikash.garodia@xxxxxxxxxxxxxxxx>
> > > ---
> > > drivers/media/platform/qcom/iris/Makefile | 1 +
> > > .../platform/qcom/iris/iris_platform_sm8550.c | 71 ++++++++++++++++++++++
> > > .../platform/qcom/iris/iris_platform_sm8550.h | 24 ++------
> > > .../media/platform/qcom/iris/iris_platform_vpu3x.c | 4 ++
> > > 4 files changed, 80 insertions(+), 20 deletions(-)
> > >
> > > +const struct iris_context_bank_ops sm8550_cb_ops = {
> >
> > For a long time I have been asking to fix name prefixes. Now you are
> > adding one more. No. Please write it as a rule of thumb. All new symbols
> > in the iris driver should start with iris_.
>
> Ack
>
> >
> > Moreover, there is nothing sm8550-specific in these hooks. Enable them
> > for all VPU3.x platforms uniformly.
>
> Good observation, will change this something like below;
> .cb_ops = &vpu3x_cb_ops,
Please see few lines above, that's a bad name.
Also, is there a reason to introduce a separate struct for those
callbacks? Can we fit them into the existing iris_vpu_ops?
> and the callbacks can be added in iris_platform_vpu3x.c
--
With best wishes
Dmitry