[PATCH rdma-next 0/2] RDMA: Small batch of cleanups
From: Leon Romanovsky
Date: Mon Jul 13 2026 - 04:15:10 EST
This series contains two independent cleanups. One fixes the problematic placemen
of a newly introduced in-kernel API, which should be called at the beginning of
destroy functions and not at the end. The other removes a redundant memset().
Thanks.
Signed-off-by: Leon Romanovsky <leonro@xxxxxxxxxx>
---
Leon Romanovsky (2):
RDMA/bnxt_re: Validate udata before destroying resources
RDMA: Remove redundant memset() from query_device callbacks
drivers/infiniband/hw/bnxt_re/ib_verbs.c | 21 ++++++++++-----------
drivers/infiniband/hw/efa/efa_verbs.c | 1 -
drivers/infiniband/hw/erdma/erdma_verbs.c | 2 --
drivers/infiniband/hw/hns/hns_roce_main.c | 2 --
drivers/infiniband/hw/irdma/verbs.c | 1 -
drivers/infiniband/hw/mana/main.c | 1 -
drivers/infiniband/hw/mlx4/main.c | 2 --
drivers/infiniband/hw/mlx5/main.c | 1 -
drivers/infiniband/hw/mthca/mthca_provider.c | 2 --
drivers/infiniband/hw/ocrdma/ocrdma_verbs.c | 1 -
drivers/infiniband/hw/qedr/verbs.c | 2 --
drivers/infiniband/hw/usnic/usnic_ib_verbs.c | 1 -
drivers/infiniband/sw/siw/siw_verbs.c | 2 --
13 files changed, 10 insertions(+), 29 deletions(-)
---
base-commit: 15ae32c4a3551c4c9da457370bdfdd65d171e512
change-id: 20260712-fix-destroy-no-udata-dfa990b985ea
Best regards,
--
Leon Romanovsky <leonro@xxxxxxxxxx>