Re: [PATCH v2 2/2] mm/mm_slot.h: clean up macro parameter names in mm_slot_lookup() and mm_slot_insert()
From: Barry Song
Date: Mon Jul 13 2026 - 21:06:47 EST
On Tue, Jul 14, 2026 at 8:41 AM <xu.xin16@xxxxxxxxxx> wrote:
>
> > Hmm not sure I suggested adding a comment to explain it... or removing the
> > prefix _ from the existing macros :P
>
> Maybe I misunderstood it.
>
> >
> > > Signed-off-by: xu xin <xu.xin16@xxxxxxxxxx>
> >
> > Honestly I don't think this is really adding much, but I guess adding the
> > comment can't hurt.
>
> Agreed.
>
> Regardless, adding a comment to explain why these have to be macros would be
> better. Would it be okay if I send a new patch that merely adds the comment,
> without removing the underscore prefixes from the existing macros?
>
Yep, I would vote for this, because otherwise someone else might
try to make it static inline again in the future.
Best Regards
Barry