[PATCH v3 0/2] Two small patches to clean up mm/mm_slot.h

From: xu.xin16

Date: Mon Jul 13 2026 - 21:25:13 EST


From: xu xin <xu.xin16@xxxxxxxxxx>

mm_slot.h is mainly used by THP and KSM.

Patch 1 introduces mm_slot_remove() to abstract the common
hash_del() + list_del() sequence used in both khugepaged and KSM.

Patch 2 adds a comment explaining why mm_slot_lookup/insert cannot
be converted to static inline functions.

xu xin (2):
mm/mm_slot.h: add a helper function mm_slot_remove
mm/mm_slot.h: add comments for mm_slot_lookup/insert

mm/khugepaged.c | 6 ++----
mm/ksm.c | 9 +++------
mm/mm_slot.h | 11 +++++++++++
3 files changed, 16 insertions(+), 10 deletions(-)

--
2.25.1