Re: [PATCH rdma-next 0/2] RDMA: Small batch of cleanups

From: Leon Romanovsky

Date: Tue Jul 14 2026 - 02:54:33 EST


On Mon, Jul 13, 2026 at 11:10:33AM +0300, Leon Romanovsky wrote:
> This series contains two independent cleanups. One fixes the problematic placemen
> of a newly introduced in-kernel API, which should be called at the beginning of
> destroy functions and not at the end. The other removes a redundant memset().
>
> Thanks.
>
> Signed-off-by: Leon Romanovsky <leonro@xxxxxxxxxx>
> ---
> Leon Romanovsky (2):
> RDMA/bnxt_re: Validate udata before destroying resources

I'll resend this one.

> RDMA: Remove redundant memset() from query_device callbacks

And applied this.