Re: [PATCH 10/17] mm/mm_init: factor out pfn_to_zone()
From: Mike Rapoport
Date: Wed Jul 15 2026 - 01:11:54 EST
> pfn_to_zone() in sparse-vmemmap.c duplicates the zone lookup logic in
> __init_deferred_page().
>
> Move it to mm_init.c, declare it in mm/internal.h, and reuse it from
> __init_deferred_page() instead of open-coding the zone walk there.
Heh, this should be a preparatory patch instead of duplicating
pfn_to_zone in sparse-vmemmap in an earlier patch ;-)
--
Sincerely yours,
Mike.