Re: [PATCH v23 02/13] power: reset: reboot-mode: Support up to 3 magic values per mode
From: Bartosz Golaszewski
Date: Wed Jul 15 2026 - 08:31:52 EST
On Tue, 14 Jul 2026 19:16:30 +0200, Shivendra Pratap
<shivendra.pratap@xxxxxxxxxxxxxxxx> said:
> ARM PSCI vendor-specific resets, require a 32-bit reset_type and a 64-bit
> cookie as arguments. This cannot be implemented via the reboot-mode
> framework, which supports a single 32-bit argument as magic value.
>
> Extend the reboot-mode framework to support up to three 32-bit arguments
> as magic, per reboot-mode.
>
> Signed-off-by: Shivendra Pratap <shivendra.pratap@xxxxxxxxxxxxxxxx>
> ---
> drivers/power/reset/nvmem-reboot-mode.c | 10 ++++----
> drivers/power/reset/qcom-pon.c | 8 ++++---
> drivers/power/reset/reboot-mode.c | 41 +++++++++++++++++++++-----------
> drivers/power/reset/syscon-reboot-mode.c | 8 ++++---
> include/linux/reboot-mode.h | 4 +++-
Could we avoid having to modify multiple files here by just providing a new
function:
nvmem_reboot_mode_write_full()
with the prototype you proposed and making the existing
nvmem_reboot_mode_write() a thin wrapper around it?
Bart