Re: [PATCH v7 0/3] PCI: Refactor PCIe speed validation and conversion functions

From: Manivannan Sadhasivam

Date: Wed Jul 15 2026 - 09:20:09 EST



On Tue, 07 Apr 2026 21:04:47 +0800, Hans Zhang wrote:
> This series refactors PCIe speed validation and conversion logic to
> shared functions in the public header, eliminating code duplication
> and ensuring consistency across drivers.

Applied, thanks!

[1/3] PCI: Add public pcie_valid_speed() for shared validation
commit: e1c1eb1d8912bd209845f1e7fc99925412fc5af8
[2/3] PCI: Move pci_bus_speed2lnkctl2() to public header
commit: a03c77abaa802433210f193617000a3c1edd20be
[3/3] PCI: dwc: Use common speed conversion function
commit: 6fc5fcd8ec1bdba3123b8a662410cf70bffc40f0

Best regards,
--
மணிவண்ணன் சதாசிவம்