Re: [PATCH 10/17] mm/mm_init: factor out pfn_to_zone()
From: Muchun Song
Date: Thu Jul 16 2026 - 03:23:17 EST
> On Jul 15, 2026, at 13:08, Mike Rapoport <rppt@xxxxxxxxxx> wrote:
>
>> pfn_to_zone() in sparse-vmemmap.c duplicates the zone lookup logic in
>> __init_deferred_page().
>>
>> Move it to mm_init.c, declare it in mm/internal.h, and reuse it from
>> __init_deferred_page() instead of open-coding the zone walk there.
>
> Heh, this should be a preparatory patch instead of duplicating
> pfn_to_zone in sparse-vmemmap in an earlier patch ;-)
Make sense. I'll adjust the patch order to introduce pfn_to_zone() before
patch 7.
Muchun,
Thanks.
>
> --
> Sincerely yours,
> Mike.
>