[PATCH v2] staging: rtl8723bs: Split multiple assignments in _rtw_open_pktfile

From: Amin Madani

Date: Thu Jul 16 2026 - 04:40:44 EST


In _rtw_open_pktfile(), multiple variables are assigned on the same
line. According to the Linux kernel coding style, multiple assignments
on a single line should be avoided. Split them into separate lines to
improve readability.

Signed-off-by: Amin Madani <aminmadani112@xxxxxxxxx>
---
v2: Assign pktptr values directly to variables instead of chaining them,
as suggested by Dan Carpenter.
(https://lore.kernel.org/all/aZ_0OratIkUBNHmy@stanley.mountain/)

drivers/staging/rtl8723bs/os_dep/xmit_linux.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
index 4260ed5f4..ea60320c0 100644
--- a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
+++ b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
@@ -15,8 +15,10 @@ uint rtw_remainder_len(struct pkt_file *pfile)
void _rtw_open_pktfile(struct sk_buff *pktptr, struct pkt_file *pfile)
{
pfile->pkt = pktptr;
- pfile->cur_addr = pfile->buf_start = pktptr->data;
- pfile->pkt_len = pfile->buf_len = pktptr->len;
+ pfile->buf_start = pktptr->data;
+ pfile->cur_addr = pktptr->data;
+ pfile->buf_len = pktptr->len;
+ pfile->pkt_len = pktptr->len;

pfile->cur_buffer = pfile->buf_start;
}
--
2.53.0