Re: [PATCH] staging: rtl8723bs: Split multiple assignments in _rtw_open_pktfile

From: Mohammadamin

Date: Thu Jul 16 2026 - 04:47:37 EST


Hi Dan,

Thank you for the feedback. I have just submitted a v2 of this patch
with the direct assignments as suggested.

Regards,
Amin


On Thu, Jul 16, 2026 at 10:01 AM Dan Carpenter <error27@xxxxxxxxx> wrote:
>
> On Wed, Jul 15, 2026 at 08:30:03PM +0330, Amin Madani wrote:
> > In _rtw_open_pktfile(), multiple variables are assigned on the same
> > line. According to the Linux kernel coding style, multiple assignments
> > on a single line should be avoided. Split them into separate lines to
> > improve readability.
> >
> > Signed-off-by: Amin Madani <aminmadani112@xxxxxxxxx>
> > ---
> > drivers/staging/rtl8723bs/os_dep/xmit_linux.c | 6 ++++--
> > 1 file changed, 4 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
> > index 4260ed5f4..598d94f1c 100644
> > --- a/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
> > +++ b/drivers/staging/rtl8723bs/os_dep/xmit_linux.c
> > @@ -15,8 +15,10 @@ uint rtw_remainder_len(struct pkt_file *pfile)
> > void _rtw_open_pktfile(struct sk_buff *pktptr, struct pkt_file *pfile)
> > {
> > pfile->pkt = pktptr;
> > - pfile->cur_addr = pfile->buf_start = pktptr->data;
> > - pfile->pkt_len = pfile->buf_len = pktptr->len;
> > + pfile->buf_start = pktptr->data;
> > + pfile->cur_addr = pfile->buf_start;
> > + pfile->buf_len = pktptr->len;
> > + pfile->pkt_len = pfile->buf_len;
>
> https://lore.kernel.org/all/aZ_0OratIkUBNHmy@stanley.mountain/
>
> regards,
> dan carpenter
>