Re: [PATCH v4 5/7] md/raid10: replace wait loop with wait_event_idle()

From: yu kuai

Date: Thu Jul 16 2026 - 05:28:25 EST


在 2026/7/10 18:15, Abd-Alrhman Masalkhi 写道:

> The wait loop is equivalent to wait_event_idle() and can be simplified
> by usaing it for improving readability.
>
> Signed-off-by: Abd-Alrhman Masalkhi<abd.masalkhi@xxxxxxxxx>
> ---
> Changes in v4:
> - No changes.
> - Link to v3:https://lore.kernel.org/linux-raid/20260708101341.473750-6-abd.masalkhi@xxxxxxxxx/
>
> Changes in v3:
> - No changes.
> - Link to v2:https://lore.kernel.org/linux-raid/20260628142420.1051027-6-abd.masalkhi@xxxxxxxxx/
>
> Changes in v2:
> - No changes.
> - Link to v1:https://lore.kernel.org/linux-raid/20260623072456.333437-6-abd.masalkhi@xxxxxxxxx/
> ---
> drivers/md/raid10.c | 15 +++++----------
> 1 file changed, 5 insertions(+), 10 deletions(-)
Reviewed-by: Yu Kuai <yukuai@xxxxxxx>

--
Thanks,
Kuai