Re: [PATCH] libarena: use ARRAY_SIZE macro in test_rbtree.bpf.c

From: bot+bpf-ci

Date: Fri Jul 17 2026 - 04:32:07 EST


> libarena: use ARRAY_SIZE macro in test_rbtree.bpf.c
>
> The ARRAY_SIZE macro is more compact and more formal in linux source.
>
> Fixes: 6c3e8a4d4765 ("selftests/bpf: libarena: Add rbtree data structure")
> Signed-off-by: longlong yan <yanlonglong@xxxxxxxxxx>

Should this commit include a Fixes: tag? The original code in commit
6c3e8a4d4765 was functionally correct - 'sizeof(keys) / sizeof(keys[0])'
produces the same result as 'ARRAY_SIZE(keys)'. This change improves code
style and readability but doesn't fix a bug.

Fixes: tags are typically reserved for commits that correct incorrect
behavior or address actual defects.


---
AI reviewed your patch. Please fix the bug or email reply why it's not a bug.
See: https://github.com/kernel-patches/vmtest/blob/master/ci/claude/README.md

CI run summary: https://github.com/kernel-patches/bpf/actions/runs/29564321134