Re: [PATCH nf-next] ipvs: use type-safe allocation helpers in ip_vs_rht_alloc

From: Phil Sutter

Date: Fri Jul 17 2026 - 06:39:27 EST


On Thu, Jul 16, 2026 at 07:37:10PM +0530, Subasri S wrote:
> As per Documentation/process/deprecated.rst, open-coded kmalloc
> assignments for struct objects are deprecated. Replace
> kzalloc(sizeof(*ptr), GFP_KERNEL) with kzalloc_obj() and
> kvmalloc_array(n, sizeof(*ptr), GFP_KERNEL) with kvmalloc_objs()
> in ip_vs_rht_alloc().
>
> Compile tested with CONFIG_IP_VS=y and runtime tested using
> tools/testing/selftests/net/netfilter/ipvs.sh on x86_64/QEMU.
>
> Signed-off-by: Subasri S <subasris1210@xxxxxxxxx>

Reviewed-by: Phil Sutter <phil@xxxxxx>