Re: [PATCH] mtd: mpc5121_nfc: use platform for irq and ioremap

From: Miquel Raynal

Date: Fri Jul 17 2026 - 11:51:43 EST


On Mon, 13 Jul 2026 16:17:22 -0700, Rosen Penev wrote:
> Replace the open-coded of_address_to_resource() plus devm_request_mem_region()
> and devm_ioremap() sequence with a single devm_platform_ioremap_resource()
> call, which folds the resource lookup, region reservation and mapping into
> one step and returns an ERR_PTR on failure, checked with IS_ERR() and
> propagated via PTR_ERR().
>
> Switch IRQ acquisition from irq_of_parse_and_map() to platform_get_irq(),
> which only retrieves the interrupt the OF/platform core has already set up
> rather than transferring mapping ownership to the driver. Drop the now
> unneeded of_irq.h include.
>
> [...]

Applied to mtd/next, thanks!

[1/1] mtd: mpc5121_nfc: use platform for irq and ioremap
commit: 355efa360ba3b9ed242f444c69fbafa84a29a525

Patche(s) should be available on mtd/linux.git and will be
part of the next PR (provided that no robot complains by then).

Kind regards,
Miquèl