[PATCH] powerpc/85xx: register gpio-keys devices for of_platform

From: Rosen Penev

Date: Fri Jul 17 2026 - 15:23:23 EST


Add the "gpio-keys" compatible to mpc85xx_common_ids so that
gpio-keys devices described in the device tree are probed as
platform devices, matching the existing gpio-leds entry.

Assisted-by: opencode:hy3-free
Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
---
arch/powerpc/platforms/85xx/common.c | 1 +
1 file changed, 1 insertion(+)

diff --git a/arch/powerpc/platforms/85xx/common.c b/arch/powerpc/platforms/85xx/common.c
index c11deb2f50ed..50ee5f2550fa 100644
--- a/arch/powerpc/platforms/85xx/common.c
+++ b/arch/powerpc/platforms/85xx/common.c
@@ -31,6 +31,7 @@ static const struct of_device_id mpc85xx_common_ids[] __initconst = {
{ .compatible = "fsl,mpc8548-guts", },
/* Probably unnecessary? */
{ .compatible = "gpio-leds", },
+ { .compatible = "gpio-keys", },
/* For all PCI controllers */
{ .compatible = "fsl,mpc8540-pci", },
{ .compatible = "fsl,mpc8548-pcie", },
--
2.55.0