Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
From: Zi Yan
Date: Fri Jul 17 2026 - 22:59:18 EST
On Fri Jul 10, 2026 at 4:16 PM EDT, Lorenzo Stoakes wrote:
> To be consistent with the newly renamed mapping_rmap_tree_*(), rename the
> anon_vma_interval_tree_*() helpers to anon_rmap_tree_*().
>
> No functional change intended.
>
> Signed-off-by: Lorenzo Stoakes <ljs@xxxxxxxxxx>
> ---
> include/linux/mm.h | 27 ++++++++++++---------------
> mm/interval_tree.c | 30 +++++++++++++++---------------
> mm/ksm.c | 4 ++--
> mm/memory-failure.c | 2 +-
> mm/rmap.c | 10 +++++-----
> mm/vma.c | 30 +++++++++++++++---------------
> tools/testing/vma/include/stubs.h | 8 ++++----
> 7 files changed, 54 insertions(+), 57 deletions(-)
>
LGTM.
Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
--
Best Regards,
Yan, Zi