Re: [PATCHv2] ata: sata_mv: use devm clock helpers

From: Damien Le Moal

Date: Fri Jul 17 2026 - 23:01:54 EST


On 7/13/26 07:37, Rosen Penev wrote:
> Replace clk_get/clk_prepare_enable/clk_put with
> devm_clk_get_optional_enabled for both the main clock and
> per-port clocks. This eliminates the need for manual clock
> cleanup in probe error and remove paths.
>
> The err label is retained for phy_power_off cleanup, since
> devm_phy_optional_get does not manage phy power state.
>
> Assisted-by: opencode:big-pickle
> Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>

Applied to for-7.3. Thanks!

--
Damien Le Moal
Western Digital Research