Re: [PATCH] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array

From: Uwe Kleine-König (The Capable Hub)

Date: Sat Jul 18 2026 - 10:09:12 EST


On Wed, Jun 10, 2026 at 11:08:49PM +0200, Uwe Kleine-König (The Capable Hub) wrote:
> Hello,
>
> On Wed, Jun 10, 2026 at 01:13:44PM -0400, Luiz Augusto von Dentz wrote:
> > On Wed, Jun 10, 2026 at 12:59 PM Uwe Kleine-König (The Capable Hub)
> > <u.kleine-koenig@xxxxxxxxxxxx> wrote:
> > >
> > > On Mon, May 04, 2026 at 06:09:40PM +0200, Uwe Kleine-König (The Capable Hub) wrote:
> > > > Initializing a struct using list initializers is hard to read, compared
> > > > to that using named initializers is more ideomatic. Convert the macro
> > > > used to assign values in the driver's pci_device_id array accordingly.
> > > >
> > > > This change doesn't introduce any changes to the compiled array on an
> > > > x86 and an arm64 build.
> > > >
> > > > Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@xxxxxxxxxxxx>
> > > > ---
> > > > Hello,
> > > >
> > > > this is a preparing change for making struct pci_device_id::driver_data an
> > > > anonymous union (similar to
> > > > https://lore.kernel.org/all/cover.1776579304.git.u.kleine-koenig@xxxxxxxxxxxx/).
> > > > This requires named initializers for .driver_data. But even without that
> > > > this is a nice cleanup making the macro better readable.
> > > >
> > > > Gcc is happy with simplifying the assignment further using
> > > > PCI_VDEVICE(BROADCOM, BCM ## id ## _DEVICE_ID), but this is a bit fishy
> > > > because PCI_VDEVICE also assigns .class and .class_mask (using list
> > > > initializers), so I didn't convert that.
> > >
> > > In the meantime I learned that doing that would break W=1 builds, so it
> > > was a good choice to not go that path.
> > >
> > > > Once all pci_device_id use
> > > > named initializers, the two zeros can be dropped from PCI_VDEVICE and
> > > > this entry simplified accordingly.
> > >
> > > Is this patch still on someone's radar? Ideally for application in time
> > > for 7.2-rc1?
> >
> > It is no longer in patchwork so if you really want to get in please resend.
>
> Instead I unarchived the patch, so it appears in the patch list again. I
> hope this is easier for everyone (it is for me).

That didn't help, it is archived again. So I'll resend, but I still
wonder about the processes involved. Is there a bogous automation that
archives patches after a while? Or is someone archiving patches by hand
that look old? Both make patchwork as tracker somewhat useless ...

Best regards
Uwe

Attachment: signature.asc
Description: PGP signature