Re: [PATCH v3 1/2] dt-bindings: sound: add Texas Instruments TAS2557
From: Krzysztof Kozlowski
Date: Sun Jul 19 2026 - 04:33:32 EST
On Sat, Jul 18, 2026 at 01:33:59AM +0200, Gianluca Boiano wrote:
> Document the TAS2557 mono Class-D smart amplifier with an integrated
> DSP for speaker protection. The device is controlled over I2C and
> receives audio over I2S/TDM (ASI). One node can describe either a
> single mono device or, via a two-entry `reg`, a stereo pair sharing
> one bus: the physical device at each `reg` index applies that half
> (DEV_A/DEV_B) of a stereo-tuned firmware image, so no separate
> channel-selection property is needed -- device order in `reg` is
> the only configuration required, matching the convention already
> used by ti,tas2781.yaml/ti,tas2563.yaml for the same TI firmware
> toolchain. `ti,imon-slot-nos`/`ti,vmon-slot-nos` follow the same
> per-index convention for the TDM sense-data slots. `reg` is capped
> at two entries because the uCDSP firmware container only defines
> mono or two-device (DEV_A/DEV_B) types -- there is no third slot to
> extend into regardless of DT shape.
>
> The on-chip DSP boots from a firmware image generated per speaker
> design with the TI PurePath Console tuning tools; the optional
> firmware-name property selects a board-specific image, shared by
> every device in the group.
>
> Addresses review from Krzysztof Kozlowski, who questioned a
> per-node channel-selection property (an earlier ti,channel/
> ti,audio-channel design) on the grounds that it doesn't scale and
> isn't how other multi-device TI amplifiers in-tree solve the same
> problem.
This paragraph does not look useful in commit log. This is part of
changelog rather.
>
> Signed-off-by: Gianluca Boiano <morf3089@xxxxxxxxx>
> ---
> Changes in v3:
> - single-node reg-array model (up to two devices), matching
> ti,tas2781.yaml; drop ti,channel, derive DEV_A/DEV_B from reg order
> - rename ti,imon-slot-no/ti,vmon-slot-no to the plural
> ti,imon-slot-nos/ti,vmon-slot-nos arrays; firmware-name maxItems: 1
>
> Changes in v2:
> - add the four mandatory supplies to "required" (Wang Sen)
>
> .../devicetree/bindings/sound/ti,tas2557.yaml | 174 ++++++++++++++++++
> MAINTAINERS | 1 +
> 2 files changed, 175 insertions(+)
Reviewed-by: Krzysztof Kozlowski <krzysztof.kozlowski@xxxxxxxxxxxxxxxx>
Best regards,
Krzysztof