Re: [PATCH RESEND] Bluetooth: hci_bcm4377: Use named initializers for pci_device_id array

From: Sven Peter

Date: Sun Jul 19 2026 - 09:15:53 EST




On 7/18/26 19:25, Uwe Kleine-König (The Capable Hub) wrote:
Initializing a struct using list initializers is hard to read, compared
to that using named initializers is more ideomatic. Convert the macro
used to assign values in the driver's pci_device_id array accordingly.

This change doesn't introduce any changes to the compiled array on an
x86 and an arm64 build.

Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@xxxxxxxxxxxx>
---

Acked-by: Sven Peter <sven@xxxxxxxxxx>


Best,


Sven