Re: [PATCH v4 04/17] verification/rvgen: Use pathlib instead of os.path
From: Nam Cao
Date: Mon Jul 20 2026 - 03:51:39 EST
Gabriele Monaco <gmonaco@xxxxxxxxxx> writes:
> Migrate to the newer patlib library, bundled with python since 3.4 to
> increase readability over using os.path.
>
> Signed-off-by: Gabriele Monaco <gmonaco@xxxxxxxxxx>
...
> + Path(__file__).resolve().parent / "templates" / self.template_dir
That is an interesting use of the division operator.
Reviewed-by: Nam Cao <namcao@xxxxxxxxxxxxx>