Re: [PATCH v2 02/18] xfs: convert iomap ops to ->iomap_next()
From: Christoph Hellwig
Date: Mon Jul 20 2026 - 04:17:55 EST
On Fri, Jul 17, 2026 at 10:55:52AM -0700, Darrick J. Wong wrote:
> > Going back to this... "iomap_iter_fn iomap_iter" doesn't feel quite
> > right. I think there's too much naming collision with iomap_iter() and
> > struct iomap_iter, and I like how in general ->next() matches the
> > orthodox naming scheme for advancing an iterator. I think
> > "iomap_iter_next_fn next" would be the best of both worlds - I'll
> > change it to this for v3. But if you don't agree with this, please let
> > me know.
>
> Fine by me :)
Same here.