Re: [PATCH v6 04/16] usb: hub: Use assign_bit() in usb_hub_set_port_power()

From: Bartosz Golaszewski

Date: Tue Jul 21 2026 - 05:16:46 EST


On Tue, 21 Jul 2026 08:53:59 +0200, Chen-Yu Tsai <wenst@xxxxxxxxxxxx> said:
> usb_hub_set_port_power() open-codes assign_bit(). Just use the
> assign_bit() macro instead. This makes subsequent additions to
> usb_hub_set_port_power() easier to read.
>
> This change does not introduce any functional changes.
>
> Suggested-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> Signed-off-by: Chen-Yu Tsai <wenst@xxxxxxxxxxxx>
> ---

Reviewed-by: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxxxxxxxx>